解决使用新版本 Chrome 后开老版本会出错的问题

Posted by pudd on November 21, 2011

如果有尝试过在同一部电脑里同时安装过两个分支的 Chrome (当然 Canary 分支 什么不算数),那么下面这种景象你一定很熟悉:

![](http://img.chromi.org/2011/11/屏幕快照-2011-11-21-9.21.59-AM.png "Chrome-old-version-alert") >您的配置文件来自新版本谷歌浏览器 ,因此无法使用,某些功能可能无法使用,请指定其他配置文件目录或新版谷歌浏览器,或使用新版本谷歌浏览器。 每开一次老版的 Chrome 这个弹窗就会出来一次,坚持不懈,十分恼人。 一般而言,这种状况下,我们妥协一下……继续用新版本就好了(你不是很geek的吗?!) 但是 dev 分支常会出现很多令人忍无可忍的问题,所以,究竟怎么样才可以最轻松地解决这个弹窗,重返 beta stable 呢? 说起来其实非常简单,关闭掉所有 Chrome 后,删除一个叫 **Web Data** 的配置文件,重新开 Chrome 就好了。 具体路径如下: >**Windows 7 : **C:\Users\USER NAME\AppData\Local\Google\Chrome\User Data\Default\Web Data >**Mac :** ~/Library/Application Support/Google/Chrome/Default/Web Data >**Windows XP : ** C:\Documents and Settings\[USERNAME]\Local Settings\Application Data\Google\Chrome\User Data\Default\Web Data 在老的 Chrome 里,直接用这个方法就可以解决了,但是,如果你已经用上Chrome 16代目的[多账户功能](http://www.chromi.org/archives/13301)的话,还有一些工作要做:把所有账户里的 Web Data 都删除掉: ![](http://img.chromi.org/2011/11/屏幕快照-2011-11-21-9.48.45-AM.png "Chrome-Web Data") 简单地说,除了…\**Default**\下的 Web Data 外,跟 Default 文件夹同层的 **Profile_1** **Profile_2** …文件夹的 Web Data 也要清理掉! 接下来重启 Chrome 即可,继续用着有安全感的老版本吧~ Via [Chrome support forum](http://www.google.com/support/forum/p/chrome/thread?tid=37ac9c13723024b1&hl=zh-CN)