老版本显卡驱动导致 Chrome 硬件加速频繁崩溃,Google 很郁闷!

Posted by Eyon on March 5, 2011

话说 Google 最近这几个月一直都在轰轰烈烈的为 Chrome 部署硬件加速的功能,但随着使用该功能的用户越来越多,Google 发现了一个很郁闷的问题,就是使用很多用户都没有更新自己显卡驱动的习惯,导致老版本的显卡驱动在配合 Chrome 硬件加速功能之后疯狂崩溃。由于保证 Chrome 的稳定是 Google 的核心原则之一,所以 Google 只好在一些老版本显卡驱动上停止 Chrome 的硬件加速,而使用软件进行渲染。

Google 在 Chromium 官方博客里要求开发者在应用中使用硬件加速的同时,还是要照顾到这些使用老版本显卡驱动的用户,虽然在性能方面可能会大打折扣,而 Google 也在努力提供一种软件渲染的方式让这些使用老版本显卡驱动的用户能够运行一些基本的3D应用。

不过想要根本的解决这些问题,还是只有用户自己去更新显卡驱动和系统的补丁,所以 Google 号召用户在使用 Chrome 硬件加速功能之前,首先通过一下两种方式更新一下系统以及显卡驱动程序:

  • 使用最新版的操作系统,比如 Windows 7 和 Mac OS X 10.6
  • 更新所有系统补丁以及硬件驱动程序

说实在的,更新驱动程序确实是使用 Windows 操作系统非常重要的一件事情,但大多数用户都没有这方面的意识。Google 应该搞出一个机制来提醒用户必须更新显卡驱动才能使用某些功能,这样应该可以很大程度上的避免这些问题。

via ChromiumBlog,Pic via poosk